Skip to toolbar

Vimeo/Backstage videos not playing in Firefox anymore

Home Forums Technical Support Vimeo/Backstage videos not playing in Firefox anymore

Supported by (Turn Off)

This topic contains 3 replies, has 3 voices, and was last updated by  spette36 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1483476

    sundancer
    22648xp
    Cult of Games Member

    This morning I was watching the video about UHU blood effects.

    Now I wanted to watch the “Blinky” video and all I get is:

    “Oops! That wasn’t supposed to happen. Please try again in a few minutes.”

    And I get this on every vimeo video. Network analysys gives me a “503 Service Unavailable”.

    Now if I open up the same links in Edge all is working. Clearing cache and cookies didn’t help either. Even incognito mode doesn’t work anymore :S HELP @warzan and the ghosts of tech!

    #1483477

    sundancer
    22648xp
    Cult of Games Member

    Ah, it’s vimeos problem

    https://www.vimeostatus.com/

    #1483499

    limburger
    14108xp
    Cult of Games Member

    I see their billing service is operational … ‘cuz that’s way more important 😉

     

    #1553673

    spette36
    Participant
    10xp

    Oh, that’s very bad if you get this error. I also saw this video and did not get any problem. Well, today I am reading about some fresh content of powerpoint presentation writing service which I need very urgent because I have to understand it for my college work. BTW, I can send you the link of the video which you got on the problem after watching.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Supported by (Turn Off)