Skip to toolbar

Site saying I need to join to watch Xlbs

Home Forums Technical Support Site saying I need to join to watch Xlbs

Supported by (Turn Off)

This topic contains 15 replies, has 3 voices, and was last updated by  ogreblood 8 months, 2 weeks ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #1685583

    torros
    23522xp
    Cult of Games Member

    Never had this problem before. Regular payment went through 6/10 Any ideas?

    #1685605

    sundancer
    40943xp
    Cult of Games Member

    Have you had an update on your browser? Usually clearing cache and forcing a reload (CTRL + Shift +R on firefox) helps.

    #1685612

    torros
    23522xp
    Cult of Games Member

    @sundancer I’m using Chrome on my android tablet

    #1685613

    sundancer
    40943xp
    Cult of Games Member
    #1685648

    torros
    23522xp
    Cult of Games Member

    @sundancer Thanks for that. Sadly still no joy

    #1685650

    sundancer
    40943xp
    Cult of Games Member

    You could install another browser on the tablet and see if that helps you. I fear it’s a “device” problem in this case because nobody else seems to have an issue with OTT. You had a weird “need to be logged in to comment” error not long ago too, didn’t you?

    #1685651

    torros
    23522xp
    Cult of Games Member

    I’ll try Firefox.  But might be a PayPal problem maybe

     

    Edit: sadly not working on Firefox either

    • This reply was modified 10 months, 1 week ago by  torros.
    #1685738

    sundancer
    40943xp
    Cult of Games Member

    I just noticed: you’re not wearing the COG badge under your avatar so it seems like your membership didn’t get through :S

     

    #1685805

    torros
    23522xp
    Cult of Games Member

    @warzan @avernos @tom Coukd someone look into this for me please

    #1699023

    ogreblood
    1576xp
    Cult of Games Member

    I am having the same issue.

    Was a fix found?

    #1699026

    sundancer
    40943xp
    Cult of Games Member

    Have you looked at your payment method? Did you CoG subscription go through? You don’t have the CoG badge attached.

    #1699027

    ogreblood
    1576xp
    Cult of Games Member

    Paying via PayPal – that looks to be going through ok. Last payment 07/11/21.

    Same as Torros, I just get the “Join backstage” page.

    #1699028

    sundancer
    40943xp
    Cult of Games Member

    I think @tgu3 or @nakchak can help you out….

    #1699053

    torros
    23522xp
    Cult of Games Member

    @ogreblood Tom had to reconnect my membership manually

    Tom said……

    I have switched back on your access to the Cult of Games content. I’ll need to check our PayPal to make sure the correct subscription/transaction ID is linked to your account to prevent this from happening again, is this the email you used for the PayPal subscription?:

    I then confirmed my email with Tom

    #1699072

    ogreblood
    1576xp
    Cult of Games Member

    Ok cool – sounds like a relatively easy fix. I had submitted a “technical issues” email about a week ago but wondered if there was a fix from my end, in the meantime.

    Thanks both for your responses.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.

Supported by (Turn Off)